FR EN ES
FR EN ES

Forum Ankama

Naviguer dans les forums 
Trackers Ankama

[RESOLU] Souci de sandbox

Par SirJauneDeau 07 Octobre 2019 - 22:19:33

'lut,
en fermant le launcher j'ai juste eu
le temps de voir une fenêtre pop, sans
voir de quoi il s'agissait.
En le relançant rien ne se passe, donc
je tente de le lancer en ligne de commande:




- Kaihe -
le mendiant Lan, Lan le magnifique,
le banni du temple du 36ème Tonneau
0 0
Réactions 11

Salut,

Alors la j'avoue, ça me pose une colle. On a jamais vu cette histoire de sandbox, 
Tu n'arrives plus du tout a lancer le Launcher c'est ça ?

J'ai trouvé ça sur git https://github.com/electron/electron/issues/17972 :

Also see here #16631 (comment) So to make suid sandbox work you basically have to tweak the  binary this way:

  •  sudo chown root chrome-sandbox
  •  chmod 4755 chrome-sandbox
 
The issue is more severe though if running appimage/snap packages, I have not yet revealed a decent workaround for these cases. It's working if appimage is executed with  arguemnt, but this is a hack.
Score : 342

'lut,
yep impossible de lancer le launcher depuis
que je l'ai fermé et qu'une fenêtre du
launcher s'ouvrait au même moment.

Est-ce que c'est risqué de lancer l'Appimage
avec l'argument --no-sandbox ?

- Kaihe -
le mendiant Lan, Lan le magnifique,
le banni du temple du 36ème Tonneau

0 0
Score : 329

C'est peut-être un cas isolé car j'ai n'ai encore jamais rencontré ce problème. pensive

0 0
Score : 342

'lut,
faudrait ptet que je réinstalle
le launcher (complètement) du coup...

- Kaihe -
le mendiant Lan, Lan le magnifique,
le banni du temple du 36ème Tonneau

0 0
Score : 1

Salut,
Pour info, même problème de mon coté sur un Debian 10.

0 0
Score : 2

salut meme probleme aussi dofus retro et 2.5

0 0
Score : 329

Alors si j'ai bien compris, le problème vient du fait que launcher utilise une version plus récente d'Electron depuis la mise à jour 2.10.13. En effet, le sandboxing est activé par défaut depuis la version 5 d'Electron.

À partir de là, je vois au moins trois solutions :

  • Ajouter le bit de setuid au fichier chrome-sandbox contenu dans l'AppImage (chmod u+s chrome-sandbox) ;
  • Mettre le paramètre sysctl kernel.unprivileged_userns_clone à 1 (sysctl kernel.unprivileged_userns_clone=1), sachant que la valeur par défaut de ce paramètre diffère selon les distributions ;
  • Désactiver complètement le sandboxing avec --no-sandbox.

Sources :
https://www.ankama.com/fr/forum/13-changelog/347-mise-jour-7-octobre-2019
https://github.com/electron-userland/electron-builder/issues/3872
https://wiki.archlinux.org/index.php/Linux_Containers#Enable_support_to_run_unprivileged_containers_(optional)
http://permissions-calculator.org/info/#setuid


 
SirJauneDeau|15/10/2019 - 22:13:53
Par contre le problème c'est que lors d'une maj,
comme à l'instant, le launcher veut redémarrer
mais il ne le fait pas avec les options avec
lesquelles il a été lancé. Dans mon cas sans
--no-sandbox et donc il ne redémarre pas.
En plus comme j'avais déjà lancé la maj de
Wakfu... faut le réparer maintenant...

Ça serait plus simple si on avait pas à
utiliser des scripts de toutes sortes.

- Kaihe -
le mendiant Lan, Lan le magnifique,
le banni du temple du 36ème Tonneau

Oui, à mon avis il faudrait appliquer la solution 1 ou 3 à l'AppImage avant de la livrer.
0 0
Score : 342

'lut,
j'ai opté pour la dernière en ajoutant
l'option dans le script pour lancer la
version 8 de java.

cat scripts/lance_ankama_launcher_jv8.sh
#!/bin/sh
export PATH=/usr/lib/jvm/java-8-openjdk-amd64/jre/bin/:$PATH
exec ~/Ankama/Ankama_Launcher.appimage "[email protected]" --no-sandbox



- Kaihe -
le mendiant Lan, Lan le magnifique,
le banni du temple du 36ème Tonneau

0 0
Réagir à ce sujet